FreeBSD shared object libdl.so.1 not found required by vim

Problem

I had installed vim on FreeBSD but I was getting the dependency error “shared object libdl.so.1 not found required by vim” whenever I would try to use it.

Solution

As detailed from this forum I had probably messed up in my initial install of vim therefore, the suggestion is to install postmaster:


To install the port: cd /usr/ports/ports-mgmt/portmaster/ && make install clean
To add the package: pkg install portmaster

Next is to rebuild vim with all it’s dependancies


portmaster -f vim

References

Shared object “libpcre.so.1” not found

Updated

This dint work. I was working in a jailed environment, not sure if this was a case.